"Impressions" statistics for Overlay and Embeddable widgets are processed with the delay.
Incident Report for ManyChat
Resolved
This incident has been resolved.
Posted Jun 20, 2019 - 10:03 PDT
Investigating
"Impressions" statistics for Overlay and Embeddable site widgets are processed with a noticeable delay at the moment when users interact with them.
Our dev team is already working to provide a fix for this issue - more information to follow soon.
Posted Jun 20, 2019 - 07:28 PDT
This incident affected: Growth Tools.