Facebook sending duplicate opt-in messages for Ref URL Growth Tool
Incident Report for ManyChat
Identified
According to Facebook, the fix has been prepared and will be rolled out on June 1, 2020.
Posted May 26, 2020 - 23:40 PDT
Update
Facebook is investigating the issue within this report: https://developers.facebook.com/support/bugs/234525177773434/
If you're affected, feel free to provide your information in the report thread and subscribe to its notifications.
Posted May 04, 2020 - 23:07 PDT
Update
We are continuing to investigate this issue.
Posted May 03, 2020 - 10:05 PDT
Investigating
Currently 5%-10% of your bot subscribers may receive duplicated messages when opting-in through Ref URL only once. Our developers are actively working on investigating this matter together with Facebook.

The issue is coming from Facebook sending duplicate webhooks to ManyChat’s servers. Our team has filed a Facebook bug report and is actively helping Facebook with investigation of this issue. You can track the progress in this report: https://developers.facebook.com/support/bugs/239386000671228/

As a temporary workaround, we suggest building the Ref URL's opt-in message like this:
1. Starting step - Condition with 'Tag is 'Your Tag'' value
2. If the user meets this condition, they don't receive any message
3. If the user doesn't meet this condition, add 'Your Tag' and send them the actual opt-in message
Posted May 03, 2020 - 08:39 PDT
This incident affects: Message sending.