Buy Buttons attached to Image / Video blocks may not work correctly on iOS devices.
Incident Report for ManyChat
Resolved
Facebook has reported that the bug was fixed. We can confirm the same on our end.

https://developers.facebook.com/support/bugs/760785317793497/
Posted Jul 27, 2020 - 10:08 PDT
Identified
Due to certain issues on Facebook's side, Buy Buttons attached to Image or Video blocks in the flows may not work correctly on iOS devices - you may notice Buy Buttons unresponsive upon tapping them.

Messenger app versions affected by the issue include v258, v259 and v260.

You can track this bug's status in the following thread on Facebook:
https://developers.facebook.com/support/bugs/760785317793497/

More information to follow soon.
Posted Apr 28, 2020 - 12:51 PDT
This incident affected: Facebook API.