Users may have experienced issues with loading ManyChat website.
Incident Report for ManyChat
Resolved
This incident has been resolved.
Posted 22 days ago. Aug 01, 2019 - 08:56 PDT
Monitoring
Users may have experienced problems with loading ManyChat website and some services for a short amount of time. The issue is already fixed.

We're monitoring the situation at the moment.
Posted 22 days ago. Aug 01, 2019 - 05:46 PDT
This incident affected: Web Application.