Instagram messages delivery is failed
Incident Report for Manyсhat
Resolved
Instagram messages delivery should now be operational
Posted May 19, 2022 - 04:19 PDT
Monitoring
We are continuing to monitor for any further issues.
Posted May 18, 2022 - 22:54 PDT
Investigating
We are currently investigating this issue.
Posted May 18, 2022 - 18:49 PDT
This incident affected: Message sending.