Small part of users may experience issues with Broadcast sending.
Incident Report for ManyChat
Resolved
This incident has been resolved. Stuck Broadcasts should now be showing as Cancelled - please re-send them if it's still relevant.
Posted 29 days ago. Nov 15, 2018 - 01:22 PST
Investigating
Some users are experiencing issues with Broadcast sending at the moment. We're investigating the matter - this incident will be updated with further information.
Posted 29 days ago. Nov 15, 2018 - 00:39 PST
This incident affected: Message sending.